User Tools

Site Tools


informatique:cisco:vrf

tag_virtuel_virtualisation

VRF

Virtual Routing and Forwarding (VRF) est un système de “virtualisation de routeur” mis en place par Cisco ; cela permet de gérer de multiples tables de routage hermétiques sur un même routeur. On peut donc avoir plusieurs réseau avec le même adressage (IP address overlap) sur le même routeur physique.

Un VRF est associé à une interface physique ou logique (SVI, si on utilise un Catalyst 4500 par exemple) de niveau 3 ; une interface ne peut appartenir qu'à un seul VRF. En revanche on peut partager un lien physique entre plusieurs VRF, en transformant le port en switchport avec 2 vlans trunkés, et 2 SVIs appartenant chacune à un VRF.

Exemple d'utilisation entre un provider et un client :

VRF-lite

VRF-Lite is a VRF implementation without multiprotocol BGP : c'est donc une déclinaison du VRF utilisée sur un CE (Client Router) destiner à dialoguer avec un PE (Provider Router). Le VRF-lite ne supporte pas le MPLS-VRF.

VRF-lite ne supporte pas les protocoles de routage IGRP et ISIS.

Mise en place

Supposons un routeur R3 qui connecte 2 clients distincts , symbolisés par leurs routeurs respectifs R1 et R2. Chacun appartient à un réseau différent ; on va les mettre dans des VRF différents (sur R3) ; cependant cette segmentation sera transparente pour les clients.

Schéma de principe (certes un peu sommaire)

R1 (fa0/1)__
            \
             \
              (fa0/1)
                     R3
              (fa0/2)
             /
R2 (fa0/2)__/

Pour l'exemple, on va considérer l'interco R1-R3 de niveau 2 (switchport + VTI) et l'interco R2-R3 de niveau 3.

Configuration de R1

vlan 10
 name interco R1-R3
!
interface fa0/1
 description vers R3
 switchport mode trunk
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10
!
interface vlan10
 description interco avec R3
 ip address 10.0.1.1 255.255.255.0

Configuration de R2

interface fa0/2
 description interco avec R3
 ip address 10.0.1.2 255.255.255.0

Configuration de R3

  • déclaration des VRFs :
ip vrf v1
 rd 1:1
 route-target export 1:1
!
ip vrf v2
 rd 1:2
 route-target export 1:2
  • assignation de chaque interface dans un VRF
vlan 10
 name interco R1-R3
!
interface fa0/1
 description vers R1
 switchport mode trunk
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10
!
interface vlan10
 description interco avec R1
 ip vrf forwarding v1
 ip address 10.0.1.3 255.255.255.0
!
interface fa0/2
 description interco avec R2
 ip vrf forwarding v2
 ip address 10.0.2.3 255.255.255.0
  • création d'une interface de loopback par VRF
interface Loopback1
 ip vrf forwarding v1
 ip address 192.168.0.13 255.255.255.255
!
interface Loopback2
 ip vrf forwarding v2
 ip address 192.168.0.23 255.255.255.255
  • Configuration du routage : une instance par VRF
router ospf 1 vrf v1
 network 10.0.1.3 0.0.0.255 area 0
 network 192.168.0.13 0.0.0.0 area 0
 capability vrf-lite
!
router ospf 2 vrf v2
 network 10.0.2.3 0.0.0.255 area 0
 network 192.168.0.23 0.0.0.0 area 0
 capability vrf-lite

Il faut utiliser la commande capability vrf-lite quand on utilise l'OSPF.

Vérifications

Pour tester le PING, il faut préciser la VRF source dans la commande ping : exemple : test de ping de google.fr (IP=74.125.77.104) depuis l'interface loopback1 (qui a l'IP 192.168.0.13 dans le VRF v1) :

ping vrf v1 74.125.77.104 source 192.168.0.13

VRF-aware ip services

Voici une liste des services qui sont compatibles (qui tiennent compte) des VRFs ; leur implémentation -et donc leurs limitations- sont dépendante de leur plate-forme : ARP, PING, SNMP, uRPF, Syslog, Traceroute, (T)FTP, SSH, NTP.

Déconfiguration

Pour retirer une interface d'une VRF, utiliser la commande no ip vrf forwarding. Pour déconfigurer complètement une VRF, utiliser la commande no ip vrf (attention cela supprime toute la configuration liée à la VRF.

Liens

informatique/cisco/vrf.txt · Last modified: 2013/10/14 22:44 (external edit)