User Tools

Site Tools


informatique:os:ubuntu

tag_linux_debian_ubuntu

Ubuntu

Ubuntu est une distribution grand public basée sur Debian GNU/Linux. Elle existe en différentes versions basée sur différents environnements graphiques :

  • Ubuntu “classique est basée sur Gnome
  • Kubuntu est basée sur KDE
  • Ebuntu est basée sur Enlightment

… mais aussi en fonction de l'orientation des paquets préinstallés, comme Edubuntu, une version d'Ubuntu packagée pour l'éducation.

Dans les chapitres suivants, sauf exception dument explicitée, il sera question de la version Ubuntu de base.

Les dépôts apt

C'est le B.A. BA de la prise en main de cette distribution car c'est de là qu'on installe les logiciels, les mises à jours, les codecs, etc… C'est un moyen centralisé de gestion de paquets.

Les dépôts sont accessibles avec une connexion Internet ; ils contiennent un index de logiciels avec leur version.

Syntaxe du fichier /etc/apt/sources.list qui contient les directive concernant ces dépôts :

deb   http://www.serveur.tld   <branche>   <sections>   #Nom du dépôt
deb-src   http://www.serveur.tld   <branche>   <sections>   #Nom du dépôt (contenant le code source des logiciels)

Les différents dépôts :

  • main (paquets libres) et restricted (paquets non-libres) sont les dépôts qui contiennent les paquets maintenus par les développeurs d'Ubuntu (Canonical)
  • universe (paquets libres) et multiverse (paquets non-libres) sont les dépôts contenant les paquets maintenus par la communauté Ubuntu (des comités d'utilisateurs)
  • backports (rétro-portage) est la branche contenant les nouvelles versions des logiciels sorties depuis la release courante d'Ubuntu. En effet lors de la sortie d'une version d'Ubuntu, les paquets sont gelés et seuls les gros bugs et les failles de sécurité sont proposés à la mise à jour.
  • commercial ou dépôt partenaire, contient les paquets des sociétés ayant un accord commercial avec Canonical.
  • medibuntu contient les paquets qui posent des problèmes au niveau de la législation de certains pays.
  • PPA (Personal Package Archive) sont des dépôt personnels que n'importe qui peut héberger, moyennant un compte sur la plateforme launchpad.
  • proposed contient les paquets destinés aux tests, avant leur intégration dans les dépôts principaux.

Installer Enlightment

source : http://doc.ubuntu-fr.org/enlightenment, testé OK avec la version Hardy Heron

Plutôt que de désinstaller sa version d'Ubuntu et de réintaller ELbuntu, il est possible d'installer Enlightment, un environnement graphique original et classe directement comme un paquet normal. Pour cela il faut :

  • ajouter les dépôts ELbuntu en modifier les sources apt :
vi /etc/apt/sources.list
 # Depot Elbuntu
 deb http://e17.dunnewind.net/ubuntu hardy e17
 # deb-src http://e17.dunnewind.net/ubuntu hardy e17
  • ajouter la clé du dépôt afin de valider la source :
 wget -q http://e17.dunnewind.net/repo_key.asc -O- | sudo apt-key add -
  • mettre à jour la liste des paquets, puis installer e17 :
sudo apt-get update && sudo apt-get install e17

Réinstallation rapide

Récupérer les paquets installés sur l'ancien système :

dpkg --get-selections > /tmp/paquets.txt

Réinstaller ces mêmes paquets sur le système nouvelle ment installée

dpkg --set-selections < /tmp/liste_paquets.txt
dselect

Recopier /opt et /home

VAIO FE41M

Régler la luminosité de l'écran

J'ai trouvé 3 solutions sur le net, seule la dernière fonctionne chez moi :

  • Utiliser le paquet spicctrl (ne fonctionne pas chez moi)
sudo apt-get install spicctrl

On peut consulter le réglage actuel avec :

spicctrl -B
 0

et on le règle en spécifiant la luminosité (0 < luminosité < 255) :

spicctrl -b150

D'après le man cet utilitaire permet de faire d'autres trucs sympa comme (en vrac) récupérer la température, la vitesse des ventilateurs, la charge de la batterie ou configurer le bluetooth.

  • “à la mano” (ça ne fonctionne pas non plus pour moi :( )

Remplir le fichier suivant avec une valeur entre 1 et 8.

sudo cat /proc/acpi/sony/brightness
 8
sudo echo 4 > /proc/acpi/sony/brightness

Pour garder les réglages il faut modifier /proc/acpi/sony/brightness_default

  • avec smartdimmer (jamais 2 sans 3)

Il ressemble pas mal à spicctrl sauf que lui il marche :

sudo aptitude install smartdimmer

On consulte la luminosité actuelle, ici le max :

smartdimmer -g
 SmartDimmer level: 21

On peut la modifier en spécifiant une valeur entre 1 et 21 :

smartdimmer -s 10

Imprimante Canon i550

source : http://mambo.kuhp.kyoto-u.ac.jp/~takushi/#canon

Canon Pixus 550i / 850i / 950i (i550 / i850 / i950) and iP90 Driver

You can install packages by the following command:
apt-get install libcnbj-2.2 bjfilter-2.2 pstocanonbj


Cupsys will be automatically restarted and you can select printer in cupsys configuration (http://127.0.0.1:631/). Vendor is Canon and Driver is, for example, “Canon PIXUS 550i ver.2.2”.

Note: You can use iP90 with 550i driver.

Point of view ION-CS330-1-S (New York)

www.pointofview-online.com_userfiles_product-images_it_pc_th_itx-pc-2_th.jpg

Je viens de faire la modeste acquisition (pour 272 roupies :) de cette petite pépite au détour d'une rue dans le coin de Montgallet ; c'est un mini PC au format ITX (petit prix, faible encombrement, faible consommation) qui est pourvu d'un processeur Intel Atom 330 (dual core @ 1.66GHz), de 2 Go de RAM, mais surtout du nouveau chipset NVIDIA ION qui, sur le papier, lui permet de décoder les vidéos HD 1080p en hardware.

Voici les specs issues du site web de Point of View :

Processor		Intel Atom 330
Chipset			Nvidia MCP7A-ION
Graphics chipset	NVIDIA® ION™ GPU
Audio chipset		HD Audio 5.1CH
Operating system	Optional / Vista Home Premium
Memory			2GB DDR2 (max 3,5GB) DIMM
Memory speed		667 MHz
Hard disk		160GB SATA 2.5''
Optical drive		DVD-RW 8x Slim-line
Graphics output		DVI/HDMI/VGA
Audio output		Optical SPDIF, optical, Stereo
USB connections		8x USB 2.0 (8x back, 2x front)
LAN			10/100/1000 Mbps RJ-45
Front panel		Mic in, Headphone out, 2x USB 2.0
Power supply		60W
Dimensions		240 x 195 x 70 mm
Form factor		m-ITX

En vrac, d'autres machines de la même trempe que j'avais retenues :

Activer le décodage matériel

C'est pour ça que j'ai acheté cette machine : elle fait de la décompression de vidéo HD (1080p) matérielle. Mais pour cela, il faut :

  • installer les drivers NVIDIA
  • installer et configurer un lecteur de vidéo exploitant les fonctionnalités VDPAU. A l'heure ou j'écris ces lignes, seuls Mplayer et XBMC supportent le décodage matériel.

installer les drivers NVIDIA

<note> Dans les liens ci-dessous, une méthode alternative et plus simple est mentionnée : plutôt que d'installer soit-même les drivers NVIDIA, il existe des dépôts non-officiels qui les proposent sous forme de paquets. </note>

  • mettre à jour le système
sudo aptitude update && sudo aptitude safe-upgrade
  • installer les paquets suivants :
sudo apt-get install build-essential xserver-xorg-dev linux-headers-$(uname -r)
  • changement de terminal (ctrl+alt+F1) et stopper le serveur X :
sudo /etc/init.d/gdm stop
  • aller dans le répertoire ou les drivers ont été téléchargés et rendre le script exécutable
chmod +x NVIDIA-Linux-x86-185.18.36-pkg1.run
  • lancer le script
sudo ./NVIDIA-Linux-x86-185.18.36-pkg1.run
  • redémarrer la machine && enjoy
sudo shutdown -r now

installer mplayer

FIXME : compléter cette section plus sérieusement.

J'ai du installer les paquets suivants :

nvidia-180-libvdpau-dev mplayer

Et ajouter les lignes suivantes au fichiers de conf de mplayer :

sudo vi /etc/mplayer/mplayer.conf
 vo = vdpau
 vc = ffh264vdpau,ffmpeg12vdpau

Pb avec mplayer

Avec mplayer j'ai une popup récurrent qui affiche le message d'erreur suivant :

[AO_ALSA] Unable to find simple control 'PCM',0.

En fait il s'agit d'un bug dont le work-around est d'écrire en dur la sortie audio dans le fichier de conf de mplayer :

sudo vi /etc/mplayer/mplayer.conf
 ao = pulse

Ressources

Intel(R) Atom(TM) CPU  330   @ 1.60GHz
NVIDIA GPU ION (C79) at PCI:3:0:0 (GPU-0)

VDPAU API version : 0
VDPAU implementation : NVIDIA VDPAU Driver Shared Library  185.18.36  Fri Aug 14 17:50:51 PDT 2009

SURFACE GET BITS: 267.488 M/s
SURFACE PUT BITS: 225.979 M/s

MPEG DECODING (1920x1080): 57 frames/s
MPEG DECODING (1280x720): 135 frames/s
H264 DECODING (1920x1080): 50 frames/s
H264 DECODING (1280x720): 105 frames/s
VC1 DECODING (1440x1080): 66 frames/s

MIXER WEAVE (1920x1080): 232 frames/s
MIXER BOB (1920x1080): 360 fields/s
MIXER TEMPORAL (1920x1080): 82 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 112 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 29 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 32 fields/s

MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 115 fields/s

Nettoyer Ubuntu

Après plusieurs mois (voir années) d'utilisation, le disque dur “s'encrasse” de différentes données qui ne sont pas importantes et qui remplissent beaucoup d'espace ; d’où la nécessité de faire une passe pour libérer de la place.

cf : http://www.commentcamarche.net/faq/7214-faire-le-menage-dans-ubuntu-residus-de-configuration-paquets

En résumé :

# vider le cache des paquets
sudo aptitude autoclean
sudo aptitude clean
 
# supprimer les anciennes versions de noyau linux
# rechercher les versions installées : 
aptitude search linux-image-.*-generic
# afficher la version actuelle :
uname -a
# supprimer les versions précédentes en ne laissant que les 2 ou 3 dernières
sudo aptitude purge linux-image-3.2.0-35-generic

Tips

Installer chromium sous 9.10

Pour installer chromium-browser (la version libre de chrome, le navigateur de Google) sous Karmic Koala (Ubuntu 9.10) il faut ajouter ce dépôt :

vi /etc/apt/sources.list
 #chromium
 deb http://ppa.launchpad.net/chromium-daily/beta/ubuntu karmic main
 deb-src http://ppa.launchpad.net/chromium-daily/beta/ubuntu karmic main

, mettre à jour la liste des paquets :

aptitude update

… puis installer le paquet chromium-browser :

aptitude search chromium-browser

Changer l'éditeur par défaut

Par défaut l'éditeur sous Ubuntu est nano. Certaines commandes (comme visudo ou vipasswd) utilisent l'éditeur par défaut de la machine pour ouvrir des fichiers, ce qui peut être déroutant (puisque vi est mieux).

Pour vérifier l'éditeur par défaut :

env | grep EDITOR
EDITOR=vim

Pour changer l'éditeur par défaut (c'est une commande interactive) :

sudo update-alternatives --config editor

Bugs

Fuser high CPU usage

Sous Ubuntu 11.10, un bug de script php5 crontabilisé provoque des problèmes de performance :

  • créé pleins de processus zombie
ps -ef | grep fuser | wc -l
 29751
  • provoque ces messages de log :
Feb  6 16:16:15 ymir2 kernel: [932477.052687] fuser invoked oom-killer: gfp_mask=0xd0, order=1, oom_adj=0, oom_score_adj=0
Feb  6 16:16:15 ymir2 kernel: [932477.052702] fuser cpuset=/ mems_allowed=0
Feb  6 16:16:15 ymir2 kernel: [932477.052713] Pid: 1797, comm: fuser Not tainted 3.0.0-15-generic #26-Ubuntu
 

Le script en question est celui-là :

cat /etc/cron.d/php5
# Look for and purge old sessions every 30 minutes
09,39 *     * * *     root   [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -depth -mindepth 1 -maxdepth 1 -type f -cmin +$(/usr/lib/php5/maxlifetime) ! -execdir fuser -s {} 2>/dev/null \; -delete

Il est installé par défaut au moment de l'installation de PHP sous 11.10. D'après ubuntuforums, il s'agirait d'un bug et il suffit de remplacer la ligne de cron par celle qui était fourni avec la version précédente d'Ubuntu (la 11.04) :

09,39 *     * * *     root   [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -depth -mindepth 1 -maxdepth 1 -  type f -cmin +$(/usr/lib/php5/maxlifetime) -delete

Liens

informatique/os/ubuntu.txt · Last modified: 2014/06/02 12:23 by pteu